use strict;
my $str = 'Valid:
972 54-333-4444
+972-54-333-4444
02-3334444
02 3334444
023334444
050-333-4444
(+972)54-333-4444
+(972)50 333 4444
0753334444
972543334444
Invalid:
02-033-4444
23334444
02-33-4444
654-333-4444
973 54 3334444
972 054 3334444
972 02 333 4444';
my $regex = qr/^(?:(?:(\+?972|\(\+?972\)|\+?\(972\))(?:\s|\.|-)?([1-9]\d?))|(0\d{1,2}))(?:\s|\.|-)?([^0\D]{1}\d{2}(?:\s|\.|-)?\d{4})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}