import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?><a.*?>(.*?)</a>)\\s*<ul";
final String string = "<ul>\n"
+ " <li>\n"
+ " <a href=\"#o\">Первый</a>\n"
+ " </li>\n"
+ " <li>\n"
+ " <a href=\"#v\">Второй</a>\n"
+ " </li>\n"
+ " <li>\n"
+ " <a href=\"#t\">Третий</a>\n"
+ " </li>\n"
+ " <li>\n"
+ " <a href=\"#ch\">Четвертый</a>\n"
+ " </li>\n"
+ " <li>\n"
+ " <a href=\"#p\">ПÑтый</a>\n"
+ " </li>\n"
+ " <li>\n"
+ " <a href=\"#test\">ШеÑтой</a>\n"
+ " <ul>\n"
+ " <li>\n"
+ " <a href=\"#so\">ШеÑтьОдин</a>\n"
+ " </li>\n"
+ " <li>\n"
+ " <a href=\"#sd\">ШеÑтьДва</a>\n"
+ " </li>\n"
+ " <li>\n"
+ " <a href=\"#st\">ШеÑтьТри</a>\n"
+ " </li>\n"
+ " <li>\n"
+ " <a href=\"#sc\">ШеÑтьЧетыре</a>\n"
+ " </li>\n"
+ " <li>\n"
+ " <a href=\"#sp\">ШеÑтьПÑть</a>\n"
+ " </li>\n"
+ " <li>\n"
+ " <a href=\"#ss\">ШеÑтьШеÑть</a>\n"
+ " </li>\n"
+ " <li>\n"
+ " <a href=\"#sss\">ШеÑтьСемь</a>\n"
+ " </li>\n"
+ " <li>\n"
+ " <a href=\"#sv\">ШеÑтьВоÑемь</a>\n"
+ " </li>\n"
+ " <li>\n"
+ " <a href=\"#sd\">ШеÑтьДевÑть</a>\n"
+ " </li>\n"
+ " </ul>\n"
+ " </li>\n"
+ "</ul>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}