import re
regex = re.compile(r"(?><a.*?>(.*?)</a>)\s*<ul")
test_str = ("<ul>\n"
" <li>\n"
" <a href=\"#o\">Первый</a>\n"
" </li>\n"
" <li>\n"
" <a href=\"#v\">Второй</a>\n"
" </li>\n"
" <li>\n"
" <a href=\"#t\">Третий</a>\n"
" </li>\n"
" <li>\n"
" <a href=\"#ch\">Четвертый</a>\n"
" </li>\n"
" <li>\n"
" <a href=\"#p\">ПÑтый</a>\n"
" </li>\n"
" <li>\n"
" <a href=\"#test\">ШеÑтой</a>\n"
" <ul>\n"
" <li>\n"
" <a href=\"#so\">ШеÑтьОдин</a>\n"
" </li>\n"
" <li>\n"
" <a href=\"#sd\">ШеÑтьДва</a>\n"
" </li>\n"
" <li>\n"
" <a href=\"#st\">ШеÑтьТри</a>\n"
" </li>\n"
" <li>\n"
" <a href=\"#sc\">ШеÑтьЧетыре</a>\n"
" </li>\n"
" <li>\n"
" <a href=\"#sp\">ШеÑтьПÑть</a>\n"
" </li>\n"
" <li>\n"
" <a href=\"#ss\">ШеÑтьШеÑть</a>\n"
" </li>\n"
" <li>\n"
" <a href=\"#sss\">ШеÑтьСемь</a>\n"
" </li>\n"
" <li>\n"
" <a href=\"#sv\">ШеÑтьВоÑемь</a>\n"
" </li>\n"
" <li>\n"
" <a href=\"#sd\">ШеÑтьДевÑть</a>\n"
" </li>\n"
" </ul>\n"
" </li>\n"
"</ul>")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")