use strict;
my $str = '<ul>
<li>
<a href="#o">Первый</a>
</li>
<li>
<a href="#v">Второй</a>
</li>
<li>
<a href="#t">Третий</a>
</li>
<li>
<a href="#ch">Четвертый</a>
</li>
<li>
<a href="#p">ПÑтый</a>
</li>
<li>
<a href="#test">ШеÑтой</a>
<ul>
<li>
<a href="#so">ШеÑтьОдин</a>
</li>
<li>
<a href="#sd">ШеÑтьДва</a>
</li>
<li>
<a href="#st">ШеÑтьТри</a>
</li>
<li>
<a href="#sc">ШеÑтьЧетыре</a>
</li>
<li>
<a href="#sp">ШеÑтьПÑть</a>
</li>
<li>
<a href="#ss">ШеÑтьШеÑть</a>
</li>
<li>
<a href="#sss">ШеÑтьСемь</a>
</li>
<li>
<a href="#sv">ШеÑтьВоÑемь</a>
</li>
<li>
<a href="#sd">ШеÑтьДевÑть</a>
</li>
</ul>
</li>
</ul>';
my $regex = qr%(?><a.*?>(.*?)</a>)\s*<ul%p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}