$re = '%(?><a.*?>(.*?)</a>)\s*<ul%';
$str = '<ul>
<li>
<a href="#o">Первый</a>
</li>
<li>
<a href="#v">Второй</a>
</li>
<li>
<a href="#t">Третий</a>
</li>
<li>
<a href="#ch">Четвертый</a>
</li>
<li>
<a href="#p">ПÑтый</a>
</li>
<li>
<a href="#test">ШеÑтой</a>
<ul>
<li>
<a href="#so">ШеÑтьОдин</a>
</li>
<li>
<a href="#sd">ШеÑтьДва</a>
</li>
<li>
<a href="#st">ШеÑтьТри</a>
</li>
<li>
<a href="#sc">ШеÑтьЧетыре</a>
</li>
<li>
<a href="#sp">ШеÑтьПÑть</a>
</li>
<li>
<a href="#ss">ШеÑтьШеÑть</a>
</li>
<li>
<a href="#sss">ШеÑтьСемь</a>
</li>
<li>
<a href="#sv">ШеÑтьВоÑемь</a>
</li>
<li>
<a href="#sd">ШеÑтьДевÑть</a>
</li>
</ul>
</li>
</ul>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);