# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/ +/ /gm;t' <<< "Hello this is a test not cleany text! See below what happens!"