re = / +/m
str = 'Hello this is a test not cleany text! See below what happens!'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result