use strict;
my $str = 'Hello this is a test not cleany text! See below what happens!';
my $regex = qr/ +/mp;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";