$re = '/ +/m';
$str = 'Hello this is a test not cleany text! See below what happens!';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;