# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\s+(\D)/$1/gm;t' <<< " JLABCD-1 836397-BTD56517"