$re = '/^\s+(\D)/m';
$str = ' JLABCD-1 836397-BTD56517';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;