use strict;
my $str = ' JLABCD-1 836397-BTD56517';
my $regex = qr/^\s+(\D)/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";