#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([\p{L}]+[\s]*)+"
Local $sString = "ddddddddddddd d" & @CRLF & _
"ddddd" & @CRLF & _
"ddddddddddddddd" & @CRLF & _
"dd sd d wd wd wdawdaw das xxc " & @CRLF & _
" wdwad awd" & @CRLF & _
" dwa" & @CRLF & _
"da " & @CRLF & _
"dwaw+" & @CRLF & _
"" & @CRLF & _
" d " & @CRLF & _
"" & @CRLF & _
"+++++" & @CRLF & _
"" & @CRLF & _
"++++" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")