$re = '/([\p{L}]+[\s]*)+/m';
$str = 'ddddddddddddd d
ddddd
ddddddddddddddd
dd sd d wd wd wdawdaw das xxc
wdwad awd
dwa
da
dwaw+
d
+++++
++++
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);