re = /([\p{L}]+[\s]*)+/m
str = 'ddddddddddddd d
ddddd
ddddddddddddddd
dd sd d wd wd wdawdaw das xxc
wdwad awd
dwa
da
dwaw+
d
+++++
++++
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end