using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\p{L}]+[\s]*)+";
string input = @"ddddddddddddd d
ddddd
ddddddddddddddd
dd sd d wd wd wdawdaw das xxc
wdwad awd
dwa
da
dwaw+
d
+++++
++++
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}