using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^X[LC]";
string input = @"XL is good
XC is good too
XS is too small
XXL is too large";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}