$re = '/^X[LC]/m';
$str = 'XL is good
XC is good too
XS is too small
XXL is too large';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);