re = /^X[LC]/m
str = 'XL is good
XC is good too
XS is too small
XXL is too large'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end