package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^X[LC]`)
var str = `XL is good
XC is good too
XS is too small
XXL is too large`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}