package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Pattern\[\d+\]:\s*Key[^\n]*\s*Value[^\n]*`)
var str = `Pattern[1]:
Key : "key1"
Value : 100
Pattern[2]:
Key : "key2"
Value : 20
Pattern[3]:
Key : "key3"
Value : 30
Pattern[4]:
Key : "key4"
Value : 220`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}