// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"Pattern\[\d+\]:\s*Key[^\n]*\s*Value[^\n]*").unwrap();
let string = "Pattern[1]:
Key : \"key1\"
Value : 100
Pattern[2]:
Key : \"key2\"
Value : 20
Pattern[3]:
Key : \"key3\"
Value : 30
Pattern[4]:
Key : \"key4\"
Value : 220";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}