const regex = /^.*.*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*.*$', 'gm')
const str = `C:\\Windows\\SysWOW64\\wscript.exe "C:\\Users\\vagrant\\AppData\\Local\\Temp\\OneNote\\16.0\\Exported\\{CD943C96-FC1A-417A-A5B5-83A1844A2E58}\\NT\\1\\filePdf.wsf"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}