re = /^.*.*$/m
str = 'C:\\Windows\\SysWOW64\\wscript.exe "C:\\Users\\vagrant\\AppData\\Local\\Temp\\OneNote\\16.0\\Exported\\{CD943C96-FC1A-417A-A5B5-83A1844A2E58}\\NT\\1\\filePdf.wsf"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end