// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.*.*$").unwrap();
let string = "C:\\Windows\\SysWOW64\\wscript.exe \"C:\\Users\\vagrant\\AppData\\Local\\Temp\\OneNote\\16.0\\Exported\\{CD943C96-FC1A-417A-A5B5-83A1844A2E58}\\NT\\1\\filePdf.wsf\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}