#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)1[A-Z]*\/[A-Z]*\s?(?:MRS|MR|MS|DR)?\b"
Local $sString = "1SMITH/GEORGEMR" & @CRLF & _
"1SMITH/GEORGE MR" & @CRLF & _
"1SMITH/GEORGE"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")