package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)1[A-Z]*\/[A-Z]*\s?(?:MRS|MR|MS|DR)?\b`)
var str = `1SMITH/GEORGEMR
1SMITH/GEORGE MR
1SMITH/GEORGE`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}