$re = '/1[A-Z]*\/[A-Z]*\s?(?:MRS|MR|MS|DR)?\b/m';
$str = '1SMITH/GEORGEMR
1SMITH/GEORGE MR
1SMITH/GEORGE';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);