const regex = /1[A-Z]*\/[A-Z]*\s?(?:MRS|MR|MS|DR)?\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('1[A-Z]*\\\/[A-Z]*\\s?(?:MRS|MR|MS|DR)?\\b', 'gm')
const str = `1SMITH/GEORGEMR
1SMITH/GEORGE MR
1SMITH/GEORGE`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}