import re
regex = re.compile(r"<div.*?>(.*?)<\/div>", flags=re.DOTALL)
test_str = ("<div id=\"_mcePaste\">\n"
"<ul>\n"
"<li> Computer is stolen </li>\n"
"<li> Someone else has gained access to your certificate </li>\n"
"<li> Employee leaves or transfers to another department </li>\n"
"<li> Certificate is corrupted </li>\n"
"</ul>\n"
"Links:\n"
"<p>http://customs.gov.au/webdata/resources/files/digital_certificate_and_client_registrations.pdf</p>\n"
"<p></p>\n"
"</div>")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)