import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)(CHE-\\d{3}\\.\\d{3}\\.\\d{3}\\ +(IVA|TVA|MWST))";
final String string = "CHE-123.456.789 MWST\n"
+ "CHE-123.456.789 TVA\n"
+ "CHE-123.456.789 IVA\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}