const regex = /<script.*?"(http.*?)"/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<script.*?"(http.*?)"', '')
const str = `<script type="text/javascript" src="http://chrismills.la/test.js"></script>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}