$re = '/<script.*?"(http.*?)"/';
$str = '<script type="text/javascript" src="http://chrismills.la/test.js"></script>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);