re = /<script.*?"(http.*?)"/
str = '<script type="text/javascript" src="http://chrismills.la/test.js"></script>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end