# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\\/tripadvisor\\/api\\/internal\\/[.0-9]+(\\/[a-zA-Z_]+\\/?[a-zA-Z_]*).*\?[^|]*//;t' <<< "/tripadvisor/api/internal/1.10/notification_campaigns/count/helle?currency=GBP&lang=en_GB"