$re = '/\/tripadvisor\/api\/internal\/[.0-9]+(\/[a-zA-Z_]+\/?[a-zA-Z_]*).*\?[^|]*/';
$str = '/tripadvisor/api/internal/1.10/notification_campaigns/count/helle?currency=GBP&lang=en_GB';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;