use strict;
my $str = '/tripadvisor/api/internal/1.10/notification_campaigns/count/helle?currency=GBP&lang=en_GB';
my $regex = qr/\/tripadvisor\/api\/internal\/[.0-9]+(\/[a-zA-Z_]+\/?[a-zA-Z_]*).*\?[^|]*/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";