#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)(\(.*?\))((([\w ]+)?\()+)?"
Local $sString = "asd (sad)yuuy(asd) () (asda(s(asdasd)asd(asd)d)) " & @CRLF & _
"" & @CRLF & _
"(ads (sygyg)iuiuiu(as (as (asd)sad(sadasd)(sad)d)asd(as)asd))" & @CRLF & _
"" & @CRLF & _
" lnh(Ly(u)hO)GbCGfBzOKtp kSMS( n(d)L z(v( K)U) w)haMDJjjdEjIVd(I)gWFpKVajcsLcuJA " & @CRLF & _
"" & @CRLF & _
"// lnhGbCGfBzOKtp kSMShaMDJjjdEjIVdgWFpKVajcsLcuJA" & @CRLF & _
"" & @CRLF & _
"Cbup((AyW)dA(E)f((B) (HhQz (ZQ(z )QSd )Aq)r(bws ) Koza(tXn)n(uk)J)a) (lJ(u(W o)h w)spy(i(Ry)qkKANk))(d)YJ(W)(LpTwt)E()" & @CRLF & _
"" & @CRLF & _
"// CbupYJE" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"YbTc (P(FCDZwe))yqF(CB(ooH)Jw(rc)lHrpR)svHi(AZ)Uqd(n hhmk( S B )yqTLJ(TI(vf)deG m)Lt)stZmYMmDio(y Lfpd)y(uAoAHy)CVKd(gFc w)q(CSd (DUqZg)XAHa)SH" & @CRLF & _
"" & @CRLF & _
"// YbTc yqFsvHiUqdstZmYMmDioyCVKdqSH"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)