// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(\(.*?\))((([\w ]+)?\()+)?").unwrap();
let string = "asd (sad)yuuy(asd) () (asda(s(asdasd)asd(asd)d))
(ads (sygyg)iuiuiu(as (as (asd)sad(sadasd)(sad)d)asd(as)asd))
lnh(Ly(u)hO)GbCGfBzOKtp kSMS( n(d)L z(v( K)U) w)haMDJjjdEjIVd(I)gWFpKVajcsLcuJA
// lnhGbCGfBzOKtp kSMShaMDJjjdEjIVdgWFpKVajcsLcuJA
Cbup((AyW)dA(E)f((B) (HhQz (ZQ(z )QSd )Aq)r(bws ) Koza(tXn)n(uk)J)a) (lJ(u(W o)h w)spy(i(Ry)qkKANk))(d)YJ(W)(LpTwt)E()
// CbupYJE
YbTc (P(FCDZwe))yqF(CB(ooH)Jw(rc)lHrpR)svHi(AZ)Uqd(n hhmk( S B )yqTLJ(TI(vf)deG m)Lt)stZmYMmDio(y Lfpd)y(uAoAHy)CVKd(gFc w)q(CSd (DUqZg)XAHa)SH
// YbTc yqFsvHiUqdstZmYMmDioyCVKdqSH";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}