using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\(.*?\))((([\w ]+)?\()+)?";
string substitution = @"";
string input = @"asd (sad)yuuy(asd) () (asda(s(asdasd)asd(asd)d))
(ads (sygyg)iuiuiu(as (as (asd)sad(sadasd)(sad)d)asd(as)asd))
lnh(Ly(u)hO)GbCGfBzOKtp kSMS( n(d)L z(v( K)U) w)haMDJjjdEjIVd(I)gWFpKVajcsLcuJA
// lnhGbCGfBzOKtp kSMShaMDJjjdEjIVdgWFpKVajcsLcuJA
Cbup((AyW)dA(E)f((B) (HhQz (ZQ(z )QSd )Aq)r(bws ) Koza(tXn)n(uk)J)a) (lJ(u(W o)h w)spy(i(Ry)qkKANk))(d)YJ(W)(LpTwt)E()
// CbupYJE
YbTc (P(FCDZwe))yqF(CB(ooH)Jw(rc)lHrpR)svHi(AZ)Uqd(n hhmk( S B )yqTLJ(TI(vf)deG m)Lt)stZmYMmDio(y Lfpd)y(uAoAHy)CVKd(gFc w)q(CSd (DUqZg)XAHa)SH
// YbTc yqFsvHiUqdstZmYMmDioyCVKdqSH";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}