import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
    public static void main(String[] args) {
        final String regex = "(\\(.*?\\))((([\\w ]+)?\\()+)?";
        final String string = "asd (sad)yuuy(asd) () (asda(s(asdasd)asd(asd)d)) \n\n"
	 + "(ads (sygyg)iuiuiu(as (as (asd)sad(sadasd)(sad)d)asd(as)asd))\n\n"
	 + " lnh(Ly(u)hO)GbCGfBzOKtp kSMS( n(d)L z(v( K)U) w)haMDJjjdEjIVd(I)gWFpKVajcsLcuJA \n\n"
	 + "// lnhGbCGfBzOKtp kSMShaMDJjjdEjIVdgWFpKVajcsLcuJA\n\n"
	 + "Cbup((AyW)dA(E)f((B) (HhQz (ZQ(z )QSd )Aq)r(bws ) Koza(tXn)n(uk)J)a)  (lJ(u(W o)h w)spy(i(Ry)qkKANk))(d)YJ(W)(LpTwt)E()\n\n"
	 + "// CbupYJE\n\n\n"
	 + "YbTc  (P(FCDZwe))yqF(CB(ooH)Jw(rc)lHrpR)svHi(AZ)Uqd(n hhmk( S B )yqTLJ(TI(vf)deG m)Lt)stZmYMmDio(y Lfpd)y(uAoAHy)CVKd(gFc w)q(CSd  (DUqZg)XAHa)SH\n\n"
	 + "// YbTc  yqFsvHiUqdstZmYMmDioyCVKdqSH";
        final String subst = "";
        
        final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
        final Matcher matcher = pattern.matcher(string);
        
        // The substituted value will be contained in the result variable
        final String result = matcher.replaceAll(subst);
        
        System.out.println("Substitution result: " + result);
    }
}