using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"cn=[\w- ]+,ou=(?<ldap_myvalue>\w+).+,ou=people,dc=mysite,dc=com";
string input = @"cn=test-1 test,ou=outest,ou=people,dc=mysite,dc=com";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}