$re = '/cn=[\w- ]+,ou=(?<ldap_myvalue>\w+).+,ou=people,dc=mysite,dc=com/';
$str = 'cn=test-1 test,ou=outest,ou=people,dc=mysite,dc=com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);