const regex = /cn=[\w- ]+,ou=(?<ldap_myvalue>\w+).+,ou=people,dc=mysite,dc=com/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('cn=[\\w- ]+,ou=(?<ldap_myvalue>\\w+).+,ou=people,dc=mysite,dc=com', 'g')
const str = `cn=test-1 test,ou=outest,ou=people,dc=mysite,dc=com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}