#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<tagStart><[^>]+>)(?<text>[^<]+)(?<tagEnd><\/[^>]+>)"
Local $sString = "- does reliably match unnested and strictly valid markup:" & @CRLF & _
" # My name is Alan and I'm <span>an</span> <div class="someClass">artist</div>." & @CRLF & _
"" & @CRLF & _
"- does not match any nested markup:" & @CRLF & _
" # My name is Alan and I'm <span><em>an</em></span> <div><em>artist</em></div>." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")