package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<tagStart><[^>]+>)(?<text>[^<]+)(?<tagEnd><\/[^>]+>)`)
var str = `- does reliably match unnested and strictly valid markup:
# My name is Alan and I'm <span>an</span> <div class="someClass">artist</div>.
- does not match any nested markup:
# My name is Alan and I'm <span><em>an</em></span> <div><em>artist</em></div>.
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}