$re = '/(?<tagStart><[^>]+>)(?<text>[^<]+)(?<tagEnd><\/[^>]+>)/';
$str = '- does reliably match unnested and strictly valid markup:
# My name is Alan and I\'m <span>an</span> <div class="someClass">artist</div>.
- does not match any nested markup:
# My name is Alan and I\'m <span><em>an</em></span> <div><em>artist</em></div>.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);