use strict;
my $str = '- does reliably match unnested and strictly valid markup:
# My name is Alan and I\'m <span>an</span> <div class="someClass">artist</div>.
- does not match any nested markup:
# My name is Alan and I\'m <span><em>an</em></span> <div><em>artist</em></div>.
';
my $regex = qr/(?<tagStart><[^>]+>)(?<text>[^<]+)(?<tagEnd><\/[^>]+>)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}