package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`document/([-\w]+)`)
var str = `This is the paragraph which also contains link http://example.com/document/EN010001-0001, now this is some text after the link`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}