import Foundation
let pattern = #"document/([-\w]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"This is the paragraph which also contains link http://example.com/document/EN010001-0001, now this is some text after the link"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}